[Botan-devel] some errors

Ruben Quintero Lores rubenql at iti.upv.es
Mon Jul 11 14:20:29 EDT 2005


I used the Botan library for a project, all good.

Now I want to create another .h and .cc files and use Botan library
functions

when I compile I get this errors...

/usr/local/include/botan/secmem.h: In constructor
`Botan::SecureVector<T>::SecureVector(const T*, Botan::u32bit)':
/usr/local/include/botan/secmem.h:192: error: missing template arguments
antes del elemento '('
/usr/local/include/botan/secmem.h: In constructor
`Botan::SecureVector<T>::SecureVector(const Botan::MemoryRegion<T>&)':
/usr/local/include/botan/secmem.h:194: error: missing template arguments
antes del elemento '('
/usr/local/include/botan/secmem.h: In constructor
`Botan::SecureVector<T>::SecureVector(const Botan::MemoryRegion<T>&,
const Botan::MemoryRegion<T>&)':
/usr/local/include/botan/secmem.h:196: error: missing template arguments
antes del elemento '('
/usr/local/include/botan/secmem.h: In member function
`Botan::SecureBuffer<T, L>& Botan::SecureBuffer<T, L>::operator=(const
Botan::SecureBuffer<T, L>&)':
/usr/local/include/botan/secmem.h:207: error: missing template arguments
antes del elemento '('
/usr/local/include/botan/secmem.h: In member function
`Botan::SecureBuffer<T, L>& Botan::SecureBuffer<T, L>::operator=(const
Botan::MemoryRegion<T>&)':
/usr/local/include/botan/secmem.h:214: error: missing template arguments
antes del elemento '('

Obviously I never touch the Botan code...

What happen????





More information about the botan-devel mailing list