[Botan-devel] LibraryInitializer problem in Win32

Yan Shpilsky yshpilsk at stevens.edu
Sat Oct 20 10:31:33 EDT 2007


Hello,

Thanks again to Jack Lloyd for providing a working patch for the Sun 
compiler build.

The application I was working on executes perfectly on Solaris and 
Linux using SUNWspro and g++, respectively. Now that I am porting it to 
Windows, however, I am having problems executing the same Botan code.

I compiled the Windows version using Visual C++ 8, and the build had no 
issues. The program seems to execute exactly in the same way as it did 
in the POSIX platforms, but as soon as it reaches the Botan library 
initializer, I receive a strange message during runtime:

This application has requested the Runtime to terminate it in an 
unusual way.
Please contact the application's support team for more information.

I have noted that this occurs on the line:
LibraryInitializer init;

I have also tried Botan::LibraryInitializer init; and have had the same 
result.

Has anyone experienced this issue before when using Visual C++? I have 
looked around for causes of this, and this message seems to be a known 
occurrence when using various versions of Visual C++.
I have tried the several solutions I have found that others have noted 
including uninstalling Google Toolbar and applying the appropriate 
Microsoft hotfix (support.microsoft.com/kb/884538).
Nothing seems to be changing.

I'm sure it's something simple, or maybe something that I overlooked, 
but if I can't fix this issue I may have to resort to an unsupported 
compiler and try my luck.

Any help is appreciated.
Regards,
Yan



More information about the botan-devel mailing list