[Botan-devel] configure.py with Python 3

Paul Johnson botan at pjohnson.allmail.net
Fri Jul 9 12:40:03 EDT 2010


Thanks Jack,

configure.py seems to be working now, or at least its running. I have an
error which could be related to the script, or it could be something
else:

    Unknown compiler "gcc"; available options:

I thought it might be because gcc isn't on the path but I added it and
it still doesn't work. I wonder if the script may be failing to build
the list of compilers (it's the only compiler I'd expect it to find)?

I'm working on windows 7, using Qt Creator gui, which installs mingw,
but in a non-standard location.

I ran configure.py like this:

    configure.py --cc=gcc --with-tr1=none --disable-shared

Would it make sense for me to try using the configure.py script from
1.9, or do the scripts differ in other ways? Any suggestions would be
appreciated.

Thanks

Paul


On Fri, 09 Jul 2010 09:58 -0400, "Jack Lloyd" <lloyd at randombit.net>
wrote:
> On Fri, Jul 09, 2010 at 08:10:32AM +0100, botan at pjohnson.allmail.net
> wrote:
> w
> > If it's a lot of hassle, I'll install Python 2.6, but for all I know it
> > may only require minor tweaks by someone who knows what they're doing,
> > so I thought I'd ask.
> 
> The easiest solution is to use the `2to3` script, which is included in
> Python 2.6 and Python 3.1. It will make a bunch of changes which
> aren't actually necessary, but it will work. By default it will just
> print a diff of the changes it suggests, but you can use the -w flag
> to have it modify in place:
> 
> $ 2to3 -w configure.py
> 
> In 1.9, the only changes necessary for 3.1 compatability are changing
> the exception catches to 'Exception as e' style. Python 2.6 also
> supports this syntax, but unfortunately Python 2.4 does not and I
> think retaining compatability there is useful as it's still widely
> deployed. Eventually though the same script will be able to support
> 2.6+ and 3.1+ out of the box, once 2.4/2.5 compatability is no longer
> a concern.
> 
> > P.S. Incidentally, I don't know if it's changed in the latest
> > development release, but my copy of building.pdf is still saying to use
> > configure.pl, which then recommends you use configure.py - not really a
> > problem, but I thought I'd point it out.
> 
> 1.8.9's build instructions now suggest the Python version. I should
> have changed this long before that, though.
> 
> -Jack
> _______________________________________________
> botan-devel mailing list
> botan-devel at randombit.net
> http://lists.randombit.net/mailman/listinfo/botan-devel
> 



More information about the botan-devel mailing list