[botan-devel] Error During make (can't build Botan)

Brad Tilley brad at 16systems.com
Fri Dec 2 08:45:17 EST 2011


I downloaded the source (version 1.10.1) and attempted to build it in
mingw on a Windows 7 computer. Here is the configuration I used:

$ python configure.py --disable-shared

   INFO: Guessing target OS is windows (use --os to set)
   INFO: Guessing to use compiler gcc (use --cc to set)
   INFO: Guessing target processor is a x86_32/i686 (use --cpu to set)
INFO: Target is gcc-windows-x86_32-i686
   INFO: Detected gcc version 4.5.2
   INFO: Assuming gcc has TR1 (use --with-tr1=none to disable)
   INFO: Skipping, by request only - bzip2 cms cvc gnump openssl qt_mutex
zlib
   INFO: Skipping, dependency failure - md4_x86_32 md5_x86_32
serpent_x86_32 sha1_x86_32
   INFO: Skipping, incompatible CPU - aes_ni aes_ssse3 idea_sse2 mp_asm64
mp_x86_64 sha1_sse2 sha1_x86_64 simd_altivec simd_sse2
   INFO: Skipping, incompatible OS - alloc_mmap asm_x86_32 asm_x86_64
beos_stats dev_random egd fd_unix proc_walk pthreads unix_procs
   INFO: Skipping, incompatible compiler - mp_msvc64 mp_x86_32_msvc INFO:
Skipping, loaded only if needed by dependency - aes_isa_eng
asm_engine mp_generic
   INFO: Using MP module mp_x86_32
   INFO: Using SIMD module simd_scalar
   INFO: ssl: The SSL/TLS code is complex, new, and not yet reviewed,
there may be serious bugs or security issues.
   INFO: Assuming CPU is little endian
   INFO: Assuming unaligned memory access works
   INFO: Using copy to link files into build directory
   INFO: Botan 1.10.1 build setup is complete


Here is where the error occurred:


$ make

src\utils\dyn_load\dyn_load.cpp: In member function 'void*
Botan::Dynamically_Loaded_Library::resolve_symbol(const std::string&)':
src\utils\dyn_load\dyn_load.cpp:68:56: error: invalid conversion from 'int
(*)()' to 'void*'
make: *** [build\lib\utils_dyn_load.obj] Error 1

Here is the gcc version:

Using built-in specs.
COLLECT_GCC=C:\MinGW\bin\gcc.exe
COLLECT_LTO_WRAPPER=c:/mingw/bin/../libexec/gcc/mingw32/4.5.2/lto-wrapper.exe
Target: mingw32
Configured with: ../gcc-4.5.2/configure
--enable-languages=c,c++,ada,fortran,objc,obj-c++
--disable-sjlj-exceptions --with-dwarf2 --enable-shared --enable-libgomp
--disable-win32-registry --enable-libstdcxx-debug
--enable-version-specific-runtime-libs --disable-werror --build=mingw32
--prefix=/mingw
Thread model: win32
gcc version 4.5.2 (GCC)

I tried passing --with-tr1=none to the config. Same error. Any suggestions?

Thanks,

Brad









More information about the botan-devel mailing list