[botan-devel] Cannot build botan under Unix system

Erwan Treguer erwanage at gmail.com
Wed Jul 20 07:01:28 EDT 2011


Here's my new Makefile:

NAME    =    EPIM_Crypt
SRC    =    main.cpp \
        EPIM_Crypt.cpp

OBJ    =    $(SRC:.cpp=.o)
RM    =    rm -f
INCLUDE    =    -I. -I./botan/include -L./botan/lib/
LDFLAGS =    -lbotan
CFLAGS    +=    -W -Wall -ansi -pedantic $(INCLUDE)
CC    =    g++

all:    $(NAME)

$(NAME): $(OBJ)
    $(CC) $(OBJ) -o $(NAME) $(LDFLAGS)

$(OBJ): $(SRC)
    $(CC) $(CFLAGS) $(SRC)

clean:
    $(RM) $(OBJ)
    $(RM) *~
    $(RM) *#

fclean:        clean
    $(RM) $(NAME)

re: fclean all

.PHONY: all clean re fclean


I tried to build my project under ubuntu 10. But I still get the same
"undifined reference".
I built the lib from the sources. As it wasn't working I tried to install
botan from the package but it didn't work more.

Can someone help me pls?


-- 
Erwan Treguer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.randombit.net/pipermail/botan-devel/attachments/20110720/f8c76d54/attachment.html>


More information about the botan-devel mailing list