[botan-devel] Dropping support for GCC 4.7/Clang 3.2 in 1.11.x

Jack Lloyd lloyd at randombit.net
Wed Jun 17 07:08:56 EDT 2015


In an attempt to make it clear what compilers are/are not supported
for Botan 1.11 we're putting together an official compiler support
list. One question on this is if older compilers like GCC 4.7 and
Clang 3.2 should be included. They nominally work but are not being
tested by the CI system or with any regularity by developers, so there
are often problems. And at this point these releases are a few years
old and most distributions have moved to newer versions. So the
thought is it might be better to cleanly break, start requiring
features added in GCC 4.8 and Clang 3.3, and ensure that the
configurations that are supported are all actually being tested
regularly.

Comments? Would removing support for GCC 4.7 or Clang 3.2 impact
anyone in a major way?

Discussion is on github at https://github.com/randombit/botan/issues/111

Thanks,
  Jack


More information about the botan-devel mailing list