Hello,<br><br>I find I am getting the same compiler issue first report in June 2007 to this list to which it appears no resolution was posted:<br><br><a href="http://lists.randombit.net/pipermail/botan-devel/2007-June/000372.html">http://lists.randombit.net/pipermail/botan-devel/2007-June/000372.html</a><br>
<br>I am using the stock code out of the box for v1.8.8 and am using gcc 3.4.6 on 32 bit Centos 4.<br><br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In member function `Botan::MemoryVector<T>& Botan::MemoryVector<T>::operator=(const Botan::MemoryRegion<T>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:310: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In constructor `Botan::MemoryVector<T>::MemoryVector(const T*, Botan::u32bit)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:326: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In constructor `Botan::MemoryVector<T>::MemoryVector(const Botan::MemoryRegion<T>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:332: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In constructor `Botan::MemoryVector<T>::MemoryVector(const Botan::MemoryRegion<T>&, const Botan::MemoryRegion<T>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:341: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In member function `Botan::SecureVector<T>& Botan::SecureVector<T>::operator=(const Botan::MemoryRegion<T>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:362: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In constructor `Botan::SecureVector<T>::SecureVector(const T*, Botan::u32bit)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:378: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In constructor `Botan::SecureVector<T>::SecureVector(const Botan::MemoryRegion<T>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:386: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In constructor `Botan::SecureVector<T>::SecureVector(const Botan::MemoryRegion<T>&, const Botan::MemoryRegion<T>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:395: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In member function `Botan::SecureBuffer<T, L>& Botan::SecureBuffer<T, L>::operator=(const Botan::SecureBuffer<T, L>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:416: error: missing template arguments before '(' token<br>../../src/Botan-1.8.8/build/include/botan/secmem.h: In member function `Botan::SecureBuffer<T, L>& Botan::SecureBuffer<T, L>::operator=(const Botan::MemoryRegion<T>&)':<br>
../../src/Botan-1.8.8/build/include/botan/secmem.h:433: error: missing template arguments before '(' token<br><br>When I ran the python configure I had to pass: --with-tr1-implementation=none or it would not compile out of the box.  I also ran 'make check' successfully and 'check --validate'<br>
<br>Thanks.<br><br>-William<br>